Announcement

Collapse
No announcement yet.

Products not updating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Products not updating

    Hi,
    I'm having an issue with updating products from withing the FS2Crew Product Manager. I own a license on the CRJ and Fenix addons and every time I launch the FS2Crew Product Manager it tells me there are updates for both addons. When I click the yellow 'Update' button I get a UAC prompt asking me to continue installing. I click yes and see the spinning arrows as if the addons are actually updating. But even after half an hour the arrows still spin. The log files show nothing related to this issue, no warnings or anything, just some lines about folder discovery and if I have the Store version or Steam version.

    I tried uninstalling everything FS2 related, registry keys and files. It's driving me nuts now and I do like to update the products so I can continue using them,

    Any idea on how to fix this, or is it possible to download and install the .exe files manually?

    Edit: I'm using Windows 11, got enough storage available and even with admin rights the addons won't update.

  • #2
    Maybe it's a Firewall / Anti Virus issue.

    Please try disabling them. Also run the Product Manager with Admin rights. Right click on the desktop short cut and select run as Admin.
    B. York
    FS2Crew Developer
    www.fs2crew.com

    Comment


    • #3
      I can also attest to having this problem, disabled windows firewall and anti-virus. Version 1.1.51, if this is the most up-to-date version, my bad, but received email re updates. Cheers

      Comment


      • #4
        Originally posted by Bryan View Post
        Maybe it's a Firewall / Anti Virus issue.

        Please try disabling them. Also run the Product Manager with Admin rights. Right click on the desktop short cut and select run as Admin.
        Hi,
        Done this, to no result unfortunately. I checked my logs and no FS2crew domain is blocked (I see traffic going to your hosting service). The installation never starts, I found the executables in the %LOCALAPPDATA%\FS2CrewTemp folder, moved the executables to a different folder and ran both files, but the installer doesn't work. It is as if the installer closes itself directly after launching (you briefly see the outline of the install wizard and then poof.. gone).

        Edit: Forgot to mention, event viewer > applications doesn't report any critical/warning issue about the installer disappearing.
        Last edited by Nyana; 09-05-2022, 09:24 PM.

        Comment


        • #5
          Are you in an Admin account?

          Also confirm that FS2Crew was not running when you tried to update.
          B. York
          FS2Crew Developer
          www.fs2crew.com

          Comment


          • #6
            Also try uninstalling the product prior to updating.
            B. York
            FS2Crew Developer
            www.fs2crew.com

            Comment


            • #7
              Hi Bryan,
              I've done all that, the admin thing, the uninstalling, everything from removing files to registry keys. The products don't update. But what I think that what goes wrong, is that the command center doesn't get the installation successful status returned.

              When I compare the Fenix executable with the command center I see this:
              Click image for larger version  Name:	Screenshot 2022-09-10 202500.jpg Views:	1 Size:	114.6 KB ID:	392

              And the Command Center:
              Click image for larger version  Name:	Screenshot 2022-09-10 202527.jpg Views:	1 Size:	52.9 KB ID:	393

              So, it appears to be that the plugins got updated, but command center doesn't know it.
              Attached Files

              Comment


              • #8
                Hmmm, the question is why?
                B. York
                FS2Crew Developer
                www.fs2crew.com

                Comment


                • #9
                  I can no longer download updates via the FS2Crew Product Manager, I also disabled Windows Firewall

                  Comment


                  • #10
                    Try connecting the computer internet via a tether on your phone. Maybe your ISP is blocking it?
                    B. York
                    FS2Crew Developer
                    www.fs2crew.com

                    Comment

                    Working...
                    X